[Logic] 64비트 로직에서 32비트 플러그인 실행하기

제 컴퓨터는 맥북프로 13인치입니다. 구입할때 램을 8기가로 업그레이드를 했죠. 그런데 Logic(이하 ‘로직’)의 경우 32비트와 64비트로 실행이 가능한데, 8기가 램을 인식하는 것이 64비트라고 합니다. 저는 여태까지 아무 생각없이 로직을 썼었는데, 어느날 보니까 로직이 32비트로 실행되고 있지 않겠습니까? 아차 싶어서 로직을 64비트로 변경하여 실행을 시켰죠.

로직을 64비트로 변경하여 실행하는 법은 다음과 같습니다.

  1. Finder에서 ‘응용프로그램’으로 갑니다.
  2. ‘응용프로그램’ 중  Logic pro로 가서 오른쪽 버튼 클릭 > 정보가져오기 선택 (혹은 단축키 command+i)
  3. ’32비트 모드에서 열기’ 체크해지


사실 아주 간단합니다.

그런데 64비트로 실행을 해보니까 문제가 발생한 것이, 다른 플러그인들은 괜찮았은데, Auto-tune 7 native(이하 ‘오토튠’)이 인식이 되질 않는 것이었습니다. 그래서 제작사 홈페이지로 들어가서 오토튠을 64비트 버전으로 다운 받아 설치했습니다. 이번에는 인식이 되었는데, 인증이 되질 않는 것이었습니다. 이래 저래 알아보다가 이메일로 물어본 결과는 매우 간단했습니다. “64비트 버전을 업그레이드 구매해라”.

네,, 제가 구입한 오토튠은 32비트버전이었고, 64비트 버전을 쓰기 위해서는 유료 업그레이드를 해야 했습니다. 업그레이드 비용이 79달러 였기 때문에 엄청 고민했습니다. 이래저래 알아보니까 32비트 플러그인을 64비트 시퀀서에서 인식시켜주는 프로그램인 Jbrige라는 것도 있어서 그걸 또 알아봤더니, 윈도우 전용이더군요.

그런데 이상한건 로직에 32비트 플러그인 호환이 자동으로 된다는 것이었습니다. 호환이 자동으로 되는데 왜 제가 가지고 있던 오토튠은 인식이 안되는가 찾아보다가 다음과 같은 사이트에서 해답을 찾았습니다.

http://www.midiforumkorea.com/index.php?option=com_kunena&func=view&catid=16&id=13085&Itemid=226#13088

요지는, 32비트 플러그인을 64비트 로직에서 실행은 자동으로 되는데, 인식을 하기 위해서는 32비트 플러그인을 설치한 뒤, 32비트로 로직을 실행시켜서 해당 플러그인을 인식하고, 그 다음에 다시 로직을 64비트로 재시작해야된다는 것이었습니다.

저도 그래서 그렇게 해보았더니 되더군요! 32비트 로직을 실해한 다음에 오디오유닛매니저에서 오토튠을 스캔 및 인증한 뒤에 다시 64비트로 로직을 실행시키니 오토튠이 인식됩니다.

이렇게 플러그인을 보면 Audio Units (32-bits)라는 카테고리로 따로 묶이며, 실행시키면 32-bit Audio Unit Bridge라는 프로그램이 실행됩니다.

이제 여기서 가운데를 클릭하면 해당 플러그인이 실행됩니다. 이걸 몰랐으면 괜한돈을 쓸뻔했네요. (물론 64비트 플러그인의 장점이 있겠지만, 당장 돈이 부족한지라….) 혹시 저와 같은 상황이신 분들이 있으시다면 참고하시길 바랍니다.

1 thought on “[Logic] 64비트 로직에서 32비트 플러그인 실행하기

  1. 오토튠 프로그램 혹시 점 받을수 잇을가요ㅜㅜ 맥북을 사서 로직과 큐베이스를 깔앗는데 오토튠이 플러그인이 안되더라구요 윈도우에선 가능한데 혹시 95youngstar@naver.com 으로 가능하다면 부탁드릴게여ㅜㅜㅜㅜ 죄송합니다

댓글 남기기

이 사이트는 스팸을 줄이는 아키스밋을 사용합니다. 댓글이 어떻게 처리되는지 알아보십시오.